Funzione SE di Excel

immagine che mostra la funzione se excel

 

SE e solo SE saprai rispondere alla domanda:

"Di che colore era il cavallo bianco di Napoleone?"

potrai utilizzare la funzione SE di Excel.

 

SE la tua risposta è stata bianco ALLORA rispondi alle prossime domande

utilizzando VERO o FALSO


Domanda 1. "Il cavallo di Napoleone era morello (cioè tutto nero) ?
Domanda 2. "Il cavallo di Napoleone era bianco?

Se alla domanda 1 hai riposto FALSO e alla 2 VERO allora sei pronto per utilizzare

la funzione SE di Excel perchè il suo funzionamento è regolato da:

  • Una condizione
  • Una cosa da fare, se la condizione è VERA
  • Una cosa da fare, se la condizione è FALSA

 


Dal manuale della funzione SE di Excel vediamo che è così strutturata:

SE(test; se_vero; se_falso)


e ora dalla teoria passa alla pratica, apri il foglio Excel allegato (in fondo alla pagina trovi il link "Excel funzione SE.xls")

 

freccia in basso con elenco dei punti"Funzione SE Excel" Esempio 1
La risposta corretta al quesito di riga 2 è Bianco! Otterrai i complimenti se avrai impostato il contenuto della cella B2 a "Bianco" ALTRIMENTI, in tutti gli altri casi, ti verrà espresso rammarico.

Nella cella B3, dove apparirà la verifica alla tua domanda, la formula sarà:


=SE(B2="Bianco";"Bravo, è la risposta giusta";"Noooo, dai riprova")

 

  • il test ovvero "la condizione" testata è che il contenuto della cella B2 sia Bianco
    • ==> =SE ( B2="Bianco;

 

  • il se_vero si verifica SE la condizione testata è soddisfatta
    • e quindi si verifica SE hai messo "Bianco" nella cella B2
    • ==> "Bravo, è la risposta giusta";

 

  • il se_falso si verifica SE la condizione testata non è soddisfatta

 

  • e quindi si verifica per ogni condizione diversa da "Bianco"
    • ==> "Noooo, dai riprova"

 

freccia in basso con elenco dei punti"Funzione SE Excel" Esempio 2

La risposta corretta al quesito di riga 4 è "è FALSO", infatti un cavallo bianco non può essere sauro!

Ora guarda la funzione SE di Excel nella cella C4


=SE(B4="è VERO";"Nooo la risposta è sbagliata";"Bravo la risposta è giusta")



Ho complicato un po' le cose... infatti

 

  • il test ovvero "la condizione" testata è che il contenuto della cella B4 sia "è VERO"
    • ovvero il contrario della risposta corretta
    • ==> =SE ( =SE(B4="è VERO";

 

  • il se_vero si verifica SE la condizione testata è soddisfatta
    • e quindi si verifica SE hai messo "è VERO" nella cella B4
    • ovvero il contrario della risposta corretta
    • di conseguenza, essendo il contrario della risposta corretta, devo dire
    • ==> "Nooo la risposta è sbagliata";

 

  • il se_falso si verifica SE la condizione testata non è soddisfatta
    • e quindi si verifica SE hai messo "è FALSO" nella cella B4
    • ovvero la risposta corretta
    • di conseguenza, essendo la risposta corretta, devo dire
    • ==> "Bravo la risposta è giusta"

freccia in basso con elenco dei punti"Funzione SE Excel" Esempio 3


La risposta corretta al quesito di riga 5 è "è VERO", infatti un cavallo bianco è bianco!
Ora analizziamo la funzione SE Excel nella cella C5



=SE(B5<>"è VERO";"Nooo la risposta è sbagliata";"Bravo la risposta è giusta")



  • il test ovvero "la condizione" testata è che il contenuto della cella B5 sia diverso da "è VERO"
    • ovvero il contrario della risposta corretta
    • ==> =SE(B5<>"è VERO";

 

  • il se_vero si verifica SE la condizione testata è soddisfatta
    • quindi si verifica SE hai messo un valore diverso da "è VERO" ("è FALSO") nella cella B5
    • ovvero il contrario della risposta corretta
    • di conseguenza, essendo il contrario della risposta corretta, devo dire
    • ==> "Nooo la risposta è sbagliata";

 

  • il se_falso si verifica SE la condizione testata non è soddisfatta
    • e quindi si verifica SE hai messo un valore diverso da "è FALSO" ("è VERO") nella cella B5
    • ovvero la risposta corretta
    • di conseguenza, essendo la risposta corretta, devo dire
    • => "Bravo la risposta è giusta"



La funzione SE di Excel è composta da una condizione che se soddisfatta esegue quanto contenuto in se_vero altimenti esegue quanto contenuto in se_falso.

 

punto esclamativo di attenzioneIl trucchetto più famoso della funzione SE di Excel

La funzione SE Excel è comunemente usata per evitare di "sporcare" le celle che contengono le funzioni senza i dati necessari per il calcolo. Questa condizione si verifica quando crei più righe di quelle che ti servono per utilizzi futuri. Le funzioni inutilizzate restituirebbero un valore del tipo VERO, FALSO o zero. In questo caso la funzione Excel SE testa la presenza del dato di input ed esegue la funzione solo SE presente ALTRIMENTI pulisce la cella risultato.

Senza la funzione SE le righe non valorizzate forniscono comunque un risultato con il SE la cella rimane vuota

Nell'esempio *non* ho utilizzato la funzione SE nell'ultima riga, il risultato? Uno zero nel risultato al posto della cella vuota.

 

risultato funzione SE Excel In questo modo, puoi copiare le formule su un numero di righe maggiore di quelle che ti servono e, quando in futuro, le utilizzerai le celle si valorizzeranno altrimenti rimarranno vuote.

 

 

 

Hai trovato questo articolo utile, bello, interessante o vuoi chiedere qualcosa in più, scrivilo nei commenti

Attachments:
Download this file (Excel funzione SE.xls)funzione-se-excel.xls[Esempi pratici della funzione SE Excel]18 Kb

Commenti  

 
-1 #10 Emilio Novelli 2013-11-05 10:55
Citazione Giulia:
Ciao ho bisogno di aiuto...io ho bisogno di usare la funzione SE con le date... mi spiego meglio in colonna A1 ho una data e io gli dico =SE(A1>01/06/2012;vero;falso) ma lui mi da vero tutto anche quando non lo è...che cosa sbaglio?? Spero di essere riuscita a spiegarmi :lol: grazie


Ciao Giulia
Prova così =SE(A1>DATA(2012;6;1);"Vero";"Falso")
Citazione
 
 
0 #9 Giulia 2013-11-04 17:03
Ciao ho bisogno di aiuto...io ho bisogno di usare la funzione SE con le date... mi spiego meglio in colonna A1 ho una data e io gli dico =SE(A1>01/06/2012;vero;falso) ma lui mi da vero tutto anche quando non lo è...che cosa sbaglio?? Spero di essere riuscita a spiegarmi :lol: grazie
Citazione
 
 
+1 #8 Fabrizio 2013-05-18 04:59
Grazie mille per la soluzione! :-) è stata molto utile!

Ciao
Citazione
 
 
0 #7 Emilio Novelli 2013-05-12 09:25
Citazione Fabrizio:
Ciao,
io dovrei copiare dati in una serie di celle ma solo se corrispondono ad un nome, la lista però da cui trasferire è composta da più celle di quante ne ho disponibili. ad es. 28 celle per verifica nome e se restituisce VERO devo trasferire i dati corrispondenti, ma ho solo 4 righe... mi aiutereste a capire come fare, per favore?
Grazie in anticipo e spero di essere stao abbastanza chiaro :-*
ciao

Ciao vediamo se ho capito, sparse nel foglio hai delle celle a cui hai attribuito un name, poi hai una lista strutturata Chiave+Valore dove la Chiave potrebbe avere il valore del name. Quando si verifica la condizione che una Chiave è il name il valore viene trasferito nella cella...
Se hai un esempio invialo a
Ciao
Citazione
 
 
-1 #6 Fabrizio 2013-05-12 05:55
Ciao,
io dovrei copiare dati in una serie di celle ma solo se corrispondono ad un nome, la lista però da cui trasferire è composta da più celle di quante ne ho disponibili. ad es. 28 celle per verifica nome e se restituisce VERO devo trasferire i dati corrispondenti, ma ho solo 4 righe... mi aiutereste a capire come fare, per favore?
Grazie in anticipo e spero di essere stao abbastanza chiaro :-*
ciao
Citazione
 
 
0 #5 Fabio 2013-01-03 09:47
Scusate ma volevo fare una domanda sulla funzione "SE" perchè una formula di questo tipo non funziona? come posso fare?
=SE(A1="Pippo";B2=C2)
se potete aiutarmi!!!
Grazie
Citazione
 
 
+4 #4 Loriane 2012-11-02 01:08
:cry: Mi spiego meglio:se voglio confrontare il totale e/o risultati di serie di operazioni diverse? [Es: SOMMA(A1:A25) quindi il totale in cella A26 con SOMMA(G2*:G48) ed il totale in cella G49 ed ottenere la risposta VERO o FALSO ?
Citazione
 
 
-1 #3 Loriane 2012-11-02 00:36
:cry: Chiarissimo, ma se dovessimo confrontare il risultato di due operazioni in celle diverse?
Citazione
 
 
+2 #2 eleonora 2012-10-12 09:13
grazie! chiarissimo :lol:
Citazione
 
 
+2 #1 Luigi 2011-10-20 13:13
:-) ottima soluzione
Citazione